• Announcements

    • Lars

      Allgemeine Forenregeln   03/13/2017

      Forenregeln Nimm dir bitte einen Moment um die nachfolgenden Regeln durchzulesen. Wenn du diese Regeln akzeptierst und die Registration fortsetzen willst, klick einfach auf den "Mit der Registrierung fortfahren"-Button. Um diese Registration abzubrechen, klick bitte einfach auf den "Zurück" Button deines Browsers. Wir garantieren nicht für die Richtigkeit, Vollständigkeit und Brauchbarkeit der Nachrichten und sind auch nicht dafür verantwortlich. Die Beiträge drücken die Meinung des Autors des Beitrags aus, nicht zwangsläufig das, wofür die Forensoftware steht. Jeder Nutzer, der denkt, dass ein veröffentlichter Beitrag unzulässig bzw. störend ist, ist aufgefordert uns unverzüglich per E-Mail zu kontaktieren. Wir haben das Recht störende Beiträge zu löschen und bemühen uns, das in einem realistischem Zeitraum zu erledigen (sofern wir beschlossen haben, dass die Löschung notwendig ist). Du akzeptierst, durchgehend während der Nutzung dieses Services, dass du dieses Forum nicht dazu missbrauchen wirst, Inhalte zu veröffentlichen, welche bewusst falsch und/oder verleumderisch, ungenau, beleidigend, vulgär, hasserfüllt, belästigend, obszön, sexuell belästigend, bedrohlich, die Privatsphäre einer Person verletzend oder in irgend einer Art und Weise das Gesetz verletzen. Des Weiteren akzeptierst du, dass du keine urheberrechtlich geschützte Inhalte ohne Erlaubnis des Besitzers in diesem Forum veröffentlichst. Mit dem Klick auf den "Mit der Registrierung fortfahren"-Button, akzeptierst du zudem unsere Datenschutzerklärung und stimmst der Speicherung deiner IP-Adresse und personenbezogenen Daten zu, die dafür benötigt werden, um dich im Falle einer rechtswidrigen Tat zurückverfolgen zu können bzw. permanent oder temporär aus dem Forum ausschließen zu können. Es besteht keine Pflicht zur Abgabe der Einwilligung, dies erfolgt alles auf freiwilliger Basis.   Zusatzinformationen Der Forenbetreiber hat das Recht, Nutzer ohne Angabe von Gründen permanent aus dem Forum auszuschließen. Des Weiteren hat er das Recht, Beiträge, Dateianhänge, Umfrage, Blogeinträge, Galleriebilder oder Signaturen ohne Angabe von Gründen zu entfernen. Mit der Registrierung verzichtest du auf alle Rechte an den von dir erstellten Inhalten, bzw. treten diese an das Unity-Insider.de und Unity-Community.de ab. Dies bedeutet im Klartext, dass das Unity-Insider.de und Unity-Community.de frei über deine Texte verfügen kann, sofern diese nicht wiederum die Rechte anderer verletzen. Es besteht weiterhin kein Anspruch von registrierten Nutzern bzw. ehemaligen registrierten Nutzern darauf, dass erstellte Inhalte und/oder die Mitgliedschaft (User) wieder gelöscht werden (Erhaltung der Konsistenz dieses Forums).   Einwilligungserklärung Wenn du mit der Speicherung deiner personenbezogenen Daten sowie den vorstehenden Regeln und Bestimmungen einverstanden bist, kannst du mit einem Klick auf den Mit der Registrierung fortfahren-Button unten fortfahren. Ansonsten drücke bitte Zurück. Stand: 07.03.2011

grinseengel

Members
  • Content count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About grinseengel

  • Rank
    Newbie
  • Birthday 03/10/1965

Profile Information

  • Gender
    Male
  • Location
    Großbeeren, Deutschland
  1. Das hast du gut erklärt und denke mal das ich das auch verstanden habe. Ich habe jetzt eine Transition von Eat zu Idle gezogen und die jeweils zurückgehenden Transitions von run zu idel und eat zu run gelöscht. Jetzt habe ich eine Kette und es funktioniert. Vielen Dank.
  2. Ok, hier ist das Bild vom Animator.
  3. Ich danke dir. Deine Tutorials haben mir schon sehr gut geholfen. Da ich die externen Modelle nicht neu exportieren kann habe ich die gesamte Animation eingeladen und dann in Unity die Phasen aufgeteilt. Das funktioniert gut. Allerdings habe ich ein neues Problem. Ich habe im Animator eine Animitionsphase zugewiesen und diese geht prima. Dann habe ich eine zweite Animationphase mit "make Transition" erstellt und zugewiesen. Auch diese funktionierten dann nacheinander. Ab der dritte Phase wurden dann nur noch zwei der drei Animationphasen dargestellt. Im Animator sehe ich die drei Phasen, sie werden aber nicht alle drei abgespielt. Was mache ich falsch?
  4. Ok, jetzt habe ich ein NPC Modell gefunden, was die Einzelanimationsphasen zeigt. Diese kann ich jetzt auch im Inspector sehen. Diese sollten dann ja wohl von Unity richtig eingeselen sein. Jetzt mein Problem mit dem Animator. Mein NPC soll im Level platziert werden und dort nur die TposeStart Animationsphase ausführen. Was muss ich jetzt machen? Geht das auch ohne eine Scriptzuweisung? Ich habe mir das in den Tutorial angesehen, verstehe das aber nicht richtig.
  5. Hallo, wieder eine Anfängerfrage. Ich habe ein externes Modell im Format .fbx. Dieses Modell hat etwa 300 Frames mit etwa 5 Animationsphasen. Das Modell habe ich normal importiert. Ich kann das Modell auch in meine Level setzen und es wird fehlerfrei angezeigt. Jetzt ist es allerdings so, dass ich nicht die einzelnen Animationsphasen zum Modell angezeigt bekomme, sondern nur die gesamte Animation mit den ca. 300 Frames. Liegt das am Import, oder müssen die einzelnen Animationsphase in Unity bestimmt werden? Evtl. liegt es ja auch schon am Quellmodell? Ich habe versucht mit dem Animator und Animation etwas anzufangen, aber da zeigt er mir logischerweise auch nichts an. Ich glaube hier fehlt mir ebenfalls wieder das Grundverständnis wie Unity arbeitet. Auch mit den Video-Turorials hat das nicht funktioniert, da ich beim Nachstellen nicht das angezeigt bekommen habe wie vorgegeben. Mein erstes Ziel ist es, einem Tiermodell eine Standanimation zu verpassen. Ich bräuchte dringend Hilfe. Evtl. habe ich mir ja auch die falschen Tutorial angesehen. Gruß, Andreas
  6. Ok! Wenn ich die Lightmap ausschalte dann erhalte ich auch keine Schatten im generierten Build, ist das richtig? Schatten erhalte ich in der Editor-Ansicht ebenfalls nicht? Wenn ich die Lightmap aktiviere, dann benötigt sowohl der Echtzeiteditor als auch der finale Build enorme Rechenzeit? Wenn ich also auf die Schatten verzichtet habe, dann kann ich die auch erst dann wieder sehen, wenn die Vorberechnungen mit Lightmap erfolgte? Ich frage nur, damit ich den Editor und die Funktionsweise besser verstehe und ich jetzt keinerlei Schatten im Editor sehen kann. EDIT: Anfrage hat sich erledigt. Habe übersehen das ich die Schatten deaktiviert hatte
  7. Hallo Zer0Cool, vielen Dank für deine schnelle Antwort. Evtl. habe ich ja mit dem Gebriff "kleines Level" etwas untertrieben. Ich habe bisher mit meinen anderen Gameengine-Versuchen als Ziel gehabt ein kleines RPG Spiel zu erstellen. Somit habe ich jetzt in Unity mit dem Terrain angefangen und wollte dieses dann nach und nach gestalten. Da ich nicht so der Terrainersteller bin habe ich mir ein Terrain im Asset-Store gekauft. Das ist ein bergiges Gras Terrain mit der Größe von 4000x4000. Dieses ist fertig textuiert. Ich glaube da bin ich dann doch etwas zu groß rangegangen. Jetzt ist mir auch klar warum ich unten rechts am Bildschirm einen Berechnungsbalken sehe. Allerdings ist da nichts mit Echtzeit, weil es etwa 4 Stunden dauert bist dieser Berechnungsbalken durchgelaufen ist. In dieser Zeit hört sich mein Rechner wie ein Düsenjäger an. Aber ich glaube immer noch, das ich die Einstellungen noch nicht richtig gewählt habe.
  8. Hallo, ich bin neu hier im Forum und bezüglich der Nutzung von Unity. In der Vergangenheit habe ich mich schon mit anderen Gameengines beschäftigt und möchte jetzt den Umstieg meistern. Es gibt ja zahlreiche Video-Tutorial die auch sehr hilfreich sind. Allerdings stehe ich jetzt vor einem Problem zu dem ich noch nichts gefunden habe. Ich suche Einstellungen im Editor mit denen ich die Qualität und damit die Dauer für die Berechnung eines Levels einstellen kann. Ich habe im Moment ein Level mit einem Terrain und ein paar kleinen Häusern erstellt. Im Prinzip nichts sonderlich aufregendes. Ich möchte ja erstmal den Einstieg hinbekommen. Jetzt zu meiner Frage: Die Berechnung dieses kleinen Levels benötigt im Moment 6 Stunden. Wenn ich da noch eine paar mehr Modelle etc. einsetze dann wird das ja eine Gedultsprobe. Ich kann mir nicht vorstellen das Unity für die Berechnung grundsätzlich so viel Zeit benötigt. Also habe ich bestimmt bei den Einstellungen etwas nicht korrekt gemacht. Kann mir jemand helfen? Gruß, Andreas