Jump to content
Unity Insider Forum

Nitec

Newbie
  • Posts

    2
  • Joined

  • Last visited

  • Days Won

    1

Nitec last won the day on October 31

Nitec had the most liked content!

Nitec's Achievements

Newbie

Newbie (1/3)

1

Reputation

  1. Hi in die weite Runde, mein Internetname ist Nitec, ich bin 26 Jahre alt und vom Beruf IT-Consultant. Ich stieg damals in jungen Jahren mit C# und XNA in die Spieleprogrammierung ein. Auch wenn ich damals in C# ohne Google nicht eine Konsolenzeile hätte ausgeben können, war ich ambitioniert genug um The Witcher 3 neuzuentwickeln. 😂 Nach vielen auf und ab und dem Aus von XNA ( 😢 ) war erstmal paar Jahre Ruhe eingetreten. Bis ich vor 5 Jahren mit Monogame wieder den Weg zur Spieleprogrammierung fand. Allerdings sah ich vor ca. 2 Jahren die Vorteile von Unity ein. Ich bin phasenweise mal mehr mal weniger mit Unity beschäftigt. Aber ich hoffe, dass ich mich eines Tages auch als Experte schimpfen darf und anderen Leuten hier im Forum meine Hilfe anbieten darf. Liebe Grüße aus dem Rheinland Nitec
  2. Liebe Community, ich habe ein Problem mit Unity beim baken von AI Navigation Meshes. Beim Versuch erscheint eine "Hold On" Meldung (siehe Screenshot) und Unity selbst friert ein. Erst mittels Task-Manager-Kill und erneutem Start, ist Unity wieder bedienbar. Unity Version: 2020.3.6f1 (LTS) Terrain: 3x3 Tiles je ca. 512x512 Vertices mittels Gaia 2021 generiert wie ihr seht, habe ich das mehr als 3h laufen lassen in der Hoffnung, dass sich doch noch etwas tut. Leider vergebens. Ich bin relativ neu in Unity. Ich vermute mal, dass sich irgendein Skript während des Events "mouseUp" dazwischenschaltet und alles blockt. Allerdings ist das Projekt sehr gewachsen (1 Jahr Entwicklung) mit mehreren Dutzenden Skripten. Deshalb weiß ich nicht, wie ich das Problem lokalisieren soll. Kennt einer das Problem oder hat Vorschläge, wie man bei sowas am besten vorgeht? EDIT 30.10. 21:46 Uhr: Ich habe eine neue Scene erstellt Unity Terrain hinzugefügt (512x512). Bake getestet => funktioniert Per Gaia Manager ein sehr kleines Tiny Terrain hinzugefügt. Bake getestet => funktioniert Per Gaia Manager sehr großes Terrain hinzugefügt. Bake getestet => selbes Verhalten wie oben beschrieben Daraus schließe ich, dass es doch etwas mit der Größe des Terrains zutun hat. Aber so groß ist das Terrain eigentlich gar nicht. Und ich hatte vorher auch schon einige Terrain-Tiles beim Baken komplett rausgenommen. Also neue Frage: was sind meine Möglichkeiten? EDIT 30.10. 22:06 Uhr: Sorry, dass ich hier die ganze Zeit reineditiere.. aber als ich in dem "Navigation" Fenster -> im Reiter "Object" -> Häkchen bei "Navigation Static" bei allen Tiles außer einem rausgenommen habe, funktionierte das baken. (läuft gerade). Dabei ist Unitys RAM-Nutzung schlagartig auf 9 GB geklettert. Konnte meine RAM-Kapazität das Problem gewesen sein? Als nächstes werde ich versuchen, alle Tiles einzeln zu baken. Wenn ich eine Lösung gefunden habe, poste ich es zusammenfassend hier. Wenn einer direkt eine Lösung parat hat, gerne EDIT 30.10. 22:37 Uhr: Also jetzt weiß ich es ganz sicher: RAM Kapazität reichte nicht aus. Während ich mit 16GB RAM ganze 3 Tiles baken konnte, kann ich jetzt mit 32GB (ich hatte noch 2 Riegel rumliegen, die ich vorhin aus Interesse eingebaut habe) ganze 6 Tiles baken. Fehlen nur noch drei Tiles..
×
×
  • Create New...