Jump to content
Unity Insider Forum
F1R3ON

3D Model Schatten Probleme

Recommended Posts

Sieht mir nach nem Meshfehler im oberen Bereich aus, unten genau das selbe. 

In der Mitte der Bereich, mhhh wirkt unscharf. Was hast du denn für Lichteinstellungen?

 

Share this post


Link to post
Share on other sites

In Blender Lamp -> Hemi in Unity Spotlight :/

 

Wie kann man so einen Meshfehler korrigieren oder gar verhindern?

Share this post


Link to post
Share on other sites

SIeht mir nach einem Normalenproblem aus (zeigen in die falsche Richtung(, lass dir die Normalen in Blender mal anzeigen (und dort korrigieren) oder überschreibe die Normalen des Modells beim Import des in Unity mit berechneten Normalen.

siehe "Normals"
A Mesh Filter together with the Mesh Renderer makes the model appear on screen

Share this post


Link to post
Share on other sites

Und Haken rein bei Generate Lightmap UV's. Da sich die Verdunkelung ständig wiederholen, glaube ich, dass die UVMap für Licht und Schatten nicht gut ist.

  • Like 1

Share this post


Link to post
Share on other sites

Hab es mit den Einstellungen von @Zer0Cool probiert leider kein Erfolg.

 

Ich bekomm den Schatten nur komplett weg, indem ich auf das GameObjekt draufklicke und unter MeshRender->Lights den Schatten ausstelle, nur wie bekomme ich einen schönen Schatten hin :/?

Share this post


Link to post
Share on other sites

Also ich konnte folgendes feststellen, dein Mesh hat keine UVs. Die Normalen scheinen zu stimmen. Ob allerdings die einzelnen Segmente bündig ausgerichtet sind ist schwer zu sagen.
Nachdem ich allerdings die UVs definiert haben und den Mesh in eine Scene gesetzt habe mit "Baked Light", hatte er trotzdem Fehler an den Kanten. Also jedenfalls musst du dem Mesh UVs verpassen, ohne UVs bekommt der Lightmapper noch mehr Probleme als ohne.

Mit UVs:
5WdlH1S.png

 

ohne UVs (Originalversion):
HVeQV4o.png

Share this post


Link to post
Share on other sites

Ich habe nun eine Weile experimentiert. Die UVs deines Mesh fehlen zwar, aber scheinbar kommt Unity auch ohne UV set klar.

Also beim Import folgendes machen:
- "Generate Lightmap UVs"
-> Advanced -> Pack Margin auf 16

Dann zum Mesh in der Szene gehen und:
- Lightmap Settings -> "Scale in Lightmap" -> 2

und "Generate Lightmaps" drücken.

Nach diesen Einstellungen hatte ich dann folgendes Ergebnis:
UeCoek7.png

Share this post


Link to post
Share on other sites

Ich gehe aber immer davon aus, daß du Lightmaps erstellst für die Meshes, also die Meshes sind "Static" und  "Scene -> Mixed Lightning" ist aktiviert!.

Im Realtime-Licht in Unity sieht dein Modell bei mir normal aus (keine Probleme mit den Schatten) ... Probleme hatte ich nur beim Baken von Licht.

Share this post


Link to post
Share on other sites

@Zer0Cool vielen Dank es klappt nun so halbwegs, da wenn ich auf Baked und Realtime wechsle dann rendert es erst die Schatten korrekt.

Ich hab dieses Problem mit allen Modeln in Blender, welches ich erzeuge, auch bei einen normalen Würfel :/

Aja und Generate Lightmaps gibt es in Unity 2017.1.3 gar nicht mehr genauso wie die Lightings anders sind als in Unity 5!

Share this post


Link to post
Share on other sites

Hab Unity 2017.3 verwendet für die obigen Szenen. Mit "Generate Lightmaps" meine ich den Button unter "Lighting" -> "Scene" 

Share this post


Link to post
Share on other sites

Ich hab leider keinen Button mit Generate Lightmaps gefunden, der Rest schon.

Weißt du nur vllt. was "No Albedo UVs" bedeutet bei den Models? :/?

Danke wirklich für deine Hilfe!!!

Share this post


Link to post
Share on other sites

Ja, dein Model hat keine UVs. Du musst deinem Modell noch UVs in Blender verpassen. Diese sind auch notwendig wenn du eine Textur auf deine Modelle legen willst. Ohne UVs kannst du deinem Modell kein Material mit einer Textur zuweisen.

Share this post


Link to post
Share on other sites

Super hat nun alles geklappt danke dir. Ja und UVs benötigt man auch für die reflektion des Lichtes oder x.x?

Danke dir nun scheint alles zu klappen. Vom Schatten bis zum Konsolen-Protokoll, danke dir!

Share this post


Link to post
Share on other sites

Ich hab nun nur ein Problem mit dem Spieler.

Wenn ich bei dem Spieler das Light -> Static mache dann bleibt der Schatten am Anfang der Szene auf seiner Position und der Schatten folgt nicht dem Spieler :/

Wie kann man das Problem lösen?

Share this post


Link to post
Share on other sites

Statische Lichtquellen sind primär für statische Objekte (unbewegliche Objekte) und nicht für bewegliche (dynamische) Objekte. Daher sollten bewegliche Objekte nicht als "static" markiert werden. Der Spieler wird prinzipiell immer über Realtime-Licht beleuchtet. Daher solltest du den Spieler nicht als "static" markieren und eine Lichtquelle in der Szene haben, die Realtimelicht abgeben kann (Realtime Light oder Mixed Light), um auch dem Spieler Licht und einen Schatten zu verpassen. Man kann dem Spieler zwar auch Licht aus "Baked"-Lichtquellen verpassen (siehe Light-Probes), aber dies würde ich nur ergänzend verwenden.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×