Jump to content
Unity Insider Forum
KaBau

längliches Terrain mit unschönen Raster / Schatten

Recommended Posts

Hi,

ich erstelle gerade mein ersten Terrain. Als Space Shooter fliege ich hierfür über dem Mond. Entsprechend hat mein Terrain folgende Maße:
Terrain Width: 50 - Breite des Sichtfeld der Camera
Terrain Lenght: 1200 - als Länge des Levels
Terrain Height: 600 - Hier möchte ich sehr tiefe Schluchten erzeugen, welche in den Mond gegraben wurden.

Nun ergeben sich beim Modellieren unschöne Effekte, weil scheinbar durch das extrem unterschiedliche Seitenverhältnis das Modellierraster in die Länge gezogen wird :
TerrainGameView.JPG.c4caa22309ee69f7b9fe500461686fda.JPGTerrainWireframe.JPG.183d97c83eb581bae7a230334328ac2c.JPGTerrainShaded.JPG.47d00f0958f2d32ffd383ee7a6f3d466.JPG

Zuerst ein Ausschnitt aus dem Game View, danach ein Ausschnitt des SceneView als "Wireframe", zuletzt ein Ausschnitt des SceneView als "Shaded"

Was kann ich einstellen, damit das Terrain ordentlich erstellt wird? Anbei meine weiteren Einstellungen - von denen ich kaum weis, was sie bewirken, da es in Tutorials immer heißt "Das sind unwichtige Einstellungen, darum müßt ihr euch nicht kümmern.":

Detail Resolution Per Patch: 8
Detail Resolution: 8
Fehlermeldung "You may reduce CPU draw call overhead by setting the detail resolution per patch as high as possible, relative to detail resolution."
Anmerkung: egal was ich bei "Detail Resolution Per Patch" eingeben: die Fehlermeldung bleibt bestehen, zumal ich nur einen Wert bis 128 eingeben kann.
Detail patches currently allocated: 1
Detail instance denssity: 262144

Base Texture Resolution 1024
Control Texture Resolution: 512
Heightmap Resolution: 512

Lightmap Static: aktiv
Scale In Lightmap: 0.0512 (habe ich nie geändert)
Lightmap Parameters: Defailt-VeryLowResolution
Fehlermeldung: "Precompute/indirect resolution for this terrain is probably too low. If the Clustering stage takes a long time, try using a higher realtime/indirect resolution setting in the Lighting windows or assign LightmapParameters that use a higher resolution setting."

Nun werden noch zwei Lightmap angezeigt: "Baked Lightmap" und "Realtime Lightmap".

Share this post


Link to post
Share on other sites

Bin jetzt nicht so erfahren mit Terrains, aber was ich so erstellt habe, kann ich nur empfehlen keine Terraingrössen zu wählen die kein symetrisches Seitenverhältniss haben.
Möchtest du trotzdem ein längliches Terrain, kannst du meine ich einfach mehrere kleine quadratische Terrains aneinanderklatschen.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Danke. Nun habe ich mein großes langes Terrain in mehrere quadratische Terrains aufgeteilt und es sieht gut aus.

Kann mir noch jemand bei den beiden Fehlermeldungen helfen? Es läuft zwar, aber ich würde gerne wissen, was ich falsch mache?
Gemäß Google Übersetzung bedeutet die erste: "Sie können den CPU-Anrufaufruf reduzieren, indem Sie die Detailauflösung pro Patch im Verhältnis zur Detailauflösung so hoch wie möglich einstellen. " Aber: ich kann nur Werte zwischen 8 und 128 eingeben, und die Meldung bleibt noch immer bestehen, und zum anderen: welche Einstellungen sind den sinnvoll, wenn das Terrain ca. 40m unter mir vorbeifliegt?

Gemäß Google Übersetzung bedeutet die zweite Meldung: " Die vorberechnete / indirekte Auflösung für dieses Gelände ist wahrscheinlich zu niedrig. Wenn die Clustering-Phase sehr lange dauert, versuchen Sie, eine höhere Einstellung für Echtzeit- / indirekte Auflösung in den Beleuchtungsfenstern zu verwenden, oder weisen Sie LightmapParameters zu, die eine höhere Auflösungseinstellung verwenden. " Bringt eine höhere Auflösung nicht eine schlechtere Performance (bei einem Mobil-Spiel)?

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×