Jump to content
Unity Insider Forum
dirk

Knacken im Audio bei hohen Geschwindigkeiten

Recommended Posts

Hallo Leute,

ich habe ein Problem mit den Audios bei hohen Geschwindigkeiten (10km/s +) bei dem ich seit langem eine Lösung suche aber bis jetzt keine gefunden habe. Vielleicht hat ja einer von euch damit Erfahrung gemacht.

Beschreibung:

Ich habe eine Weltraum Szene die einen Durchmesser von 150.000Km in Unity hat (kein Scherz oder Schreibfehler 🙂). Weltraum halt. Das funzt alles so weit. Natürlich muss sich der Spieler bei diesen Distanzen entsprechend schnell bewegen, um von einem Planeten zum nächsten zu kommen damit er nicht stundenlang unterwegs ist. Das alles funzt perfekt bis auf die Audios die bei diesen Geschwindigkeiten anfangen Knackgeräusche zu produzieren (hört sich an wie das Springen der Nadel auf alten Vinylplatten), und das je mehr je schneller man sich bewegt. Während des warpens liegen die Geschwindigkeiten so zwischen 300 - 500 Km/sek. Anfangen tut es schon bei 5km/sek und ab 10km/sek wird es dann richtig nervend. Ich benutze in dem Spiel ein Double Precision Floating Origin System. Den AudioListener schleppt der Character mit sich rum der auch im Schiff sitzt.

Was ich schon versucht habe ohne Erfolg.

  • Die Audios an den Player binden damit sie immer nah dabei sind
  • Die Audios in ein eigenes GameObject auslagern und an 0,0,0 belassen
  • Die Audios in ein eigenes GameObject auslagern und mitnehmen
  • Lautstärke ändern

Es wäre schön wenn jemand eine Lösung wüsste, da mir langsam die Ideen ausgehen. 🙄

Danke :unity:

Share this post


Link to post
Share on other sites

Ich nehme mal an, Doppler-Effekt hast du schon ausgestellt?

Ansonsten, wenn man das mit Einstellungen nicht einfach lösen kann, würde ich versuchen, eine kleine Audio-Szene zu bauen: Einen AudioListener am Nullpunkt und AudioSources in der Nähe, deren Position (und Vorhandensein) von Scripts gesteuert werden, die AudioSources ersetzen und sich dort befinden, wo die Source eigentlich wären.

Wenn das nicht so richtig hinhaut oder nicht schön genug umsetzbar ist, könnte man auch überlegen, Unitys Soundsystem links liegen zu lassen und ein anderes zu nutzen, FMOD oder so. Da hättest du dann über solche Dinge mehr Kontrolle.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Sascha,

tausend Danke. Ich habe den Doppler Effekt global ausgeschaltet und das Knacken war weg. :rolleyes:

Share this post


Link to post
Share on other sites

Hah, manchmal kann's auch einfach sein :D

Ich meine mich zu erinnern, dass es in den Project Settings beim Sound eine globale Einstellung dafür gibt. Wenn du die ausstellst, brauchst du nicht bei jeder AudioSource einzeln darauf zu achten.

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb Sascha:

Hah, manchmal kann's auch einfach sein :D

Ich meine mich zu erinnern, dass es in den Project Settings beim Sound eine globale Einstellung dafür gibt. Wenn du die ausstellst, brauchst du nicht bei jeder AudioSource einzeln darauf zu achten.

Ja genau das habe ich gemacht. 😉

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...