Jump to content
Unity Insider Forum
Sign in to follow this  
EsKannNurJp

Neuer Spieler problem

Recommended Posts

Hallo Leute.

ich habe ein Problem in Unity.
auf Youtube gibt es ein souls like zu unity.
bin jetzt bei über 100 stunden film material.(folge 30)
sprich zum nach bauen habe ich länger gebraucht.
alles funktioniert so weit bis auf ein Fehler.

Habe vor paar tagen mein Spieler verbessert die Lippen haben mir nicht gefallen,
also ist alles wie beim alten nur der Mund ist etwas schöner jetzt.
Haben den neuen Spieler auf genau die selbe Position wie den alten gesetzt und alle Componenten kopiert vom alten.
und auf den neuen hinzugefühg.
jetzt habe ich das Problem das mein Spieler die Run Animation nicht mehr richtig abspielt.
vorher hat alles geklappt.
der Spieler bewegt sich zwar aber er hängt irgend wie in der Runanimation fest.
also es sieht aus als würde er auf einem bein hüpfen.(zuckt dabei und wenn ich schnell rennen drücke schafft er es er ein schritt dann glitcht er wieder auf einem Bein).
habe auch mein alten Spieler noch mal hinzugefühgt aber selbe Problem.
ich Idiot habe leider erst den alten Spieler 1 mal aus der Hirachy gelöscht.

Jetzt weiß ich einfach nicht ob es sein kann das jetzt alles kaputt ist.
Sprich der Spieler nicht mehr zu retten ist.
was ich mir eigentlich nicht vor stellen kann.
ich glaube ich muss irgend wo im Script oder unter Einstellungen was vergessen haben.
Oder???
weil wo her soll das Script oder Unity wissen das das nicht mehr der selbe Spieler ist.
Knochen und so sind ja auch die selben.
und alle anderen Animation funktionieren (zauber  ,  Atk  ,  rollen  ,  parrieren ,  blocken , backstab  ,  idle animation  ,  heil Animation  , usw )

hoffe einer kann mir helfen nur mir sagen ob ich richtig liege.

Das ich ein Fehler gemacht haben muss also mein Set noch zu retten ist.

Oder ich durch den Spieler wechsel irgend was kaputt gemacht habe .
und alles kaputt ist.
wie gesagt es hat erst funktioniert.

 

Danke schon mal 

LG Pulver

gffgdgfggf.png

  • Confused 1

Share this post


Link to post
Share on other sites

 

 

ich weiß nicht mehr weiter.

alles andere funktioniert ja wie es sollte,

nur die rennen Animation wird seit dem wechsel nicht mehr ab gespielt.

also nicht richtig er hack auf einem bein.

aber bewegen tut er sich ja.

im Animator der Balken unter der Animation ist wie ein gefrohren.(zuckt leicht )

ich muss halt nur wissen ob es sein kann.

das durch den austausch meines Spielers.(selbe Spieler und Knochen wie der alte, nur Mund etwas verbessert)

was kaputt gehen könnte?

was ja nicht sein kann oder?

ich muss irgend was im Script falsch haben oder eine Einstellung ist raus gesprungen??

aber es kann doch nicht sein das das Set jetzt koplet kaputt ist ?

viel dank schon mal 

fehler v2.png

fehler v3.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...