Jump to content
Unity Insider Forum
Der_Stefan_

Collider greifen nicht - Grundsätzliches Physik-Problem - GELÖST!

Recommended Posts

Hallo Zusammen,

ich habe jetzt hier (und auch anderswo) schon mehrfach nach Antworten für mein Problem gesucht, doch dieses spezifische Problem nicht beantwortet bekommen. Die meisten Collider-Probleme waren da auf zu schnelle GameObjects oder zu kleine Collider zurückzuführen - Beides nicht mein Problem.

Und zwar ist es bei mir so, dass sämtliche Collider (Box, Cylinder, Mesh...) einfach von sich aus nicht mehr zu greifen scheinen. Als ob die GamePhysik nicht mehr da wäre. Meine GameObjects fallen einfach durch andere Objects (Terrain, Würfel, Plane etc.) einfach hindurch. Selbstverständlich haben alle unbeweglichen Objekte (Boden, Plattform etc.) Mesh- oder BoxCollider, die beweglichen Teile (Props, Items, Player...) ebenfalls und zusätzlich die Rigidbody-Komponente. An den Scripten kann es auch nicht liegen, ich habe noch gar keine. Bisher habe ich lediglich diverse Modelle in Blender gestaltet und ordnungsgemäß nach Unity transferiert.

Ich habe auch bereits testweise - direkt in Unity - einen neuen Würfel generiert (BoxCollider, Rigidbody) und ihn über einer Box (BoxCollider) oder einer Plane (MeshCollider (mal mit, mal ohne Convex-Einstellung)) platziert. Also absolut auf die Basis zurück. Und auch hier fällt der Würfel durch beides einfach durch. Dadurch konnte ich Blender und den Import als Verursacher ausschließen.

Danach hatte ich das VisualScripting-Tool "Bolt" in Verdacht. Bei der Installation hat es ziemlich viele Unitiy-Grundeinstellungen überschrieben. Meine Vermutung war daher, dass dadurch auch irgendwas grundsätzliches in der GamePhysik überschrieben wurde.
Um das zu prüfen habe ich eine komplett neue Datei angelegt, Test mit Würfel und Plane/Box wie oben beschrieben. Funktioniert ohne Probleme. Bolt installiert, noch immer keine Probleme. Nachträglich, MIT Bolt im Hintergrund, die Testobjekte noch mal neu erstellt. Hier ebenfalls keine Probleme, der Würfel landet sauber auf dem Boden und bleibt liegen. Somit kann ich Bolt als (grundsätzlichen) Fehler-Verursacher ebenfalls ausschließen.

als letztes habe ich dann bei dem funktionierenden Testprojekt und meinem Projekt die Preferences von Bolt und Unity selbst, ebenso wie Würfel und Plane verglichen - Alles identisch...

So langsam gehen mir echt die Ideen aus wo der Fehler liegen könnte... Habt ihr vielleicht noch einen Ansatz den ich versuchen könnte?

Danke im vorraus.

Edited by Der_Stefan_
Problem gelöst, im Titel entsprechend getagt

Share this post


Link to post
Share on other sites

Hast du vielleicht irgend etwas mit den Layern gemacht? Über die Layermatrix kann man Kollisionen unterbinden.
Sonst wüsste ich auch nicht, was da sein könnte.

Share this post


Link to post
Share on other sites

Hmm... Auf dem ersten Blick scheint alles auf dem Default-Layer zu liegen, oder was meinst du? 
Aber danke für den Hinweis, das werde ich mir heute Abend noch mal genauer angucken.

Share this post


Link to post
Share on other sites

Uff... sehr komisch. Und deine Herangehensweise beim Fehler finden klingt auch sehr gut und gründlich. Meine Ideen so auf Anhieb, so blöd sie auch sein mögen:

  • 3D- und 2D-Collider gemischt?
  • Fixed Timestep zu hoch oder andere FixedUpdate-Einstellungen (unter Project Settings/Time) schlecht gesetzt?

Share this post


Link to post
Share on other sites

Hört sich nach einem "versteckten" Projektsetting an, insofern du kein Skript in der Scene am laufen hast welches die Physik deaktiviert oder Physik-Einstellungen manipuliert. 
In solchen hartnäckigen Fällen würde ich das gesamte Projekt ohne Projekt-Settings und Cache neu von Unity laden lassen, du verlierst hier zwar alle Projektsettings, kannst aber die Settings vom alten Projekt per Hand nachtragen und weißt dann auch welche Settings wo geändert wurden.

Vorgehensweise:
1) Mach ein Backup von deinem Projekt
2) Lösche in deinem Projekt alle Folder außer "Assets" und "Packages"
3) Lade das Projekt in Unity neu - Unity erzeugt dabei Default-Projekt-Settings und neue Cache-Dateien

Sollte das Projekt danach wieder funktionieren, lag es vermutlich an einer Einstellung in den Projekt-Settings. Dabei könnte man jetzt nachträglich einen Inhaltsvergleich machen der Dateien im Folder "ProjectSettings" (Originaldateien vs. neue Dateien) um herauszufinden welches Setting es genau war.

Tippen würde ich auf "DynamicsManager.asset" hier sind alle 3D-Physik-Settings hinterlegt (oder "Physics2DSettings.asset" für 2D).

Share this post


Link to post
Share on other sites
vor 5 Stunden schrieb malzbie:

Hast du vielleicht irgend etwas mit den Layern gemacht? Über die Layermatrix kann man Kollisionen unterbinden.
Sonst wüsste ich auch nicht, was da sein könnte.

Ich danke euch für eure Ideen und Denkanstöße.

In der Layermatrix schien irgendwo tatsächlich der Fehler zu liegen. Zwar ist alles in der gleichen Ebene, Default, und in der Matrix waren auch alle Haken gesetzt, aber ein Versuch war' wert. Alle Haken entfernen, Bestätigen, noch mal in's Menü und alle Haken neu setzen, Bestätigen. Und siehe da, alles funktioniert wie es soll. Puuuh... Ich habe noch immer keine Ahnung wo der Fehler herkam, aber ich bin gerade sehr glücklich dass es trotzdem wieder läuft :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...