Jump to content
Unity Insider Forum
BeatenByBacon

Unity 3D Terrain Tree Rotation Bug

Recommended Posts

Hey Developers!
I have a little problem with the tree functions of the unity terrain. I want to use my own created trees for my game, the trees already have a single mesh with 2 materials. 
My problem now is, that for some reason, when i place them, the rotation is correct, the tree has a normal rotation (trunk in the ground, leaves facing up), but when i brush them, they all have a wrong rotation. I don't know how to fix that and I hope someone out there can help me with my problem :(

Here you can see on the right the correct rotation, on the left the placed trees with the tree brush tool:

https://i.imgur.com/ImHkRp3.png

How the prefab looks in the inspector and in the folder:

https://i.imgur.com/WqeE15x.png

Share this post


Link to post
Share on other sites

Make an empty object, place your tree prefab inside of it, make that parent object a new prefab and put that in your terrain inspector. Not sure if it works, but it's worth a try before trying something else.

Share this post


Link to post
Share on other sites

Der Stamm des Baumes (3D-Modell) muss auf der Y-Achse liegen, vermutlich liegen deine Bäume auf X oder Z.
Wenn der Baum aus Blender kommt liegt die Achse vermutlich auf Z und das muss beim Export korrigiert werden:
wsGE3.png

Der Anchor des Baumes muss zudem am Boden des Stammes liegen.

Share this post


Link to post
Share on other sites

Danke für die Antwort :)

@Sascha, daran habe ich auch schon gedacht, nur will komischerweise die Tree function nichts mit parents und childs zu tun haben. Das GameObject, also der Baum, darf anscheinend keine weiteren GameObjects besitzen, sonst wird der Baum nicht mal angezeigt 😕

@Zer0Cool, danke für die Idee, tatsächlich waren bei mir die Werte bei Blender nicht die gleichen wie in deinem Screenshot, leider hat auch das nicht funktioniert. Zwar ist mein Objekt jetzt in meinem Projekt Ordner richtig positioniert, im Inspector liegt der Baum aber immernoch auf der Seite, wenn ich ihn passiere ist das Resultat auch noch das gleiche 😕

EDIT: Es funktioniert endlich! Habe bei den Import Einstellungen über Blender die Apply Transform Funktion angetickt, jetzt lassen sich die Bäume so platzieren wie sie sollen, Vielen Dank nochmal für eure Hilfe :)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...