Jump to content
Unity Insider Forum
Sign in to follow this  
LaerA

HDRP Schatten nur im Editor

Recommended Posts

Heyho!

ich hoffe, dass mir vlt. hier jemand helfen kann. Das ist mein erstes Projekt mit der HD-Renderpipeline.. normalerweise habe ich immer die URP verwendet.
Angehangen habe ich zwei Screenshots. Das eine von denen hat keine Lichteffekte (Schatten und Beleuchtung). Das passiert jedoch nur im fertigen Build. Im Editor sieht man die Lichteffekte so, wie sie sein sollten. Hat jemand eine Idee woran das liegen könnte?

Liebe Grüße
LaerA

BuildScreenshotKeineSchatten.png

EditorScreenShotMitSchatten.png

Share this post


Link to post
Share on other sites

Hast du mal in die Quality Settings geschaut? Da sind plattformabhängige Default-Werte. Kann sein, dass dein Editor schicker eingestellt ist als die Plattform, auf die du buildest.

  • Thanks 1

Share this post


Link to post
Share on other sites

Danke für die schnelle Antwort schon mal! :-)

Das hatte ich auch schon Gedacht.. aber in den Quality Settings für HDRP kenne ich mich nicht aus. Für mich sieht das eigentlich richtig aus, magst du mal überfliegen?

Desktop Screenshot 2020.11.22 - 20.26.53.71 (2).png

Desktop Screenshot 2020.11.22 - 20.27.13.69.png

Share this post


Link to post
Share on other sites

Habe den Fehler jetzt beheben können.

Falls das noch jemandem passiert und derjenige hier landet:

Bei mir war die Lösung, dass ich angefangen habe nicht verwendete HDRP Settings aus dem Projekt zu löschen (Können z.B. bei importieren von Assets dabei sein).
Außerdem habe ich die "Shadow"-Einstellungen eines frischen Directional Light's kopiert (Bei mir war es z.B. unteranderem die Contact Shadows Einstellung, die alles kaputt gemacht hat)

Danke @Sascha trotzdem für den schnellen Input! 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...