Jump to content
Unity Insider Forum

Samsung A30s mit Unity verbinden


Recommended Posts

Hallo,

bekomme mit meinem Samsung Galaxy A30s keine Verbindung zu Unity. Im Datei-Explorer ist es zu sehen und ich kann auf alle Ordner zugreifen.

In den Projektsettings  habe ich nur zu Auswahl "None"  oder "Any Android Device". Die APP Unity Remote ist gestartet und das Handy ist mit dem Notebook verbunden. Leider scheint das nicht zu reichen. Welche Möglichkeiten habe ich eventuell noch ?

Danke Wolfgang

P.S. Mit einem A51 geht es auch nicht

Link to post
Share on other sites

 

vor 12 Stunden schrieb Sascha:

Hast du denn den Developer Mode auf dem Handy an, USB-Debugging aktiviert und deinem Rechner die Zugriffsrechte gegeben?

Danke, jep hatte ich alles gemacht, u.a. früher Mobile APPs erstellt. Bei den Zugriffsrechten weiß ich nicht so genau was Du meinst. Ich kann jedenfalls problemlos beliebig Dateien austauschen.

Habe mal zum Test eine APK erstellt. Läuft auf dem Handy. Aber Remote ist nichts zu machen. Da mein Notebook einen Tastbildschirm hat und auch im Tabletmodus arbeiten kann ist es mir jetzt egal.

Gruß Wolfgang

 

 

Link to post
Share on other sites

Dateien austauschen hat nix mit Developer Mode zu tun. Der Ablauf ist folgender:

  • Du machst den Developer Mode an (IdR irgendwas mit mehrfach auf "Über das Telefon" in den Einstellungen tippen oder so).
  • Du schaltest in den Entwickleroptionen USB-Debugging an.
  • Du verbindest das Gerät über USB mit deinem Rechner.
  • Ein Popup erscheint von wegen "wollen Sie diesem Gerät Entwickler-Zugang erlauben" mit einer Hexadezimal-ID... keine Ahnung, was das ist, ehrlich gesagt. MAC-Adresse...? Nie drauf geachtet, weil ich sowieso weiß, welches Gerät das ist - hängt ja an nem Kabel. Jedenfalls erlaubst du den Zugriff.
  • Dann startest du Unity Remote und den Editor.
  • Ggf. noch "Any Android Device" anschalten.
Link to post
Share on other sites

sorry, aber genau das ist alles passiert ???

Habe noch eine Vermutung. Wenn ich mein Samsung anschließe wird auch der Samsung USB-Treiber aktiviert. Vielleicht muss es ja der Google-Treiber sein ? leider bekomme ich das nicht hin.

Link to post
Share on other sites

Hm, da kann ich nichts zu sagen. Wenn da irgendein Treiber sofort umfassenden Kontrollanspruch auf das Gerät erhebt, dann klingt das schon ungut... aber wie gesagt, keine Ahnung. Ich habe mit verschiedenen Geräten jeweils von Motorola und OnePlus nie ernsthafte Probleme gehabt.

Link to post
Share on other sites

Problem gelöst !

Das Android-SDK über Android Studio extra geladen,  und bei "Preferences" "External Tools" (siehe Anhang) das SDK-Verzeichnis aus Android-Studio einsetzen (... installed with Unity ... vorher ausschalten). Muß jetzt noch am Bildschirmformat arbeiten, ist senkrecht und gestaucht.

Pfrereferences.jpg

Link to post
Share on other sites

Oooh richtig, der Blödsinn. Ich erinnere mich... Derselbe Pfad, aber manuell eingefügt statt automatisch. Ich meine aber, dass bei dem Problem gleichermaßen auch Builds failen, oder nicht?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...