Jump to content
Unity Insider Forum

IAPButton Klasse wird nicht mehr erkannt.


Philone117
 Share

Recommended Posts

Hi zusammen,

in meinem aktuellen Projekt nutze ich IAP Buttons um In App Käufe zu ermöglichen. Hierbei habe ich IAPButtons erstellt die nach einmaligem Kauf verschwinden sollen (SetActive(false)). Daher wurde der Button als public declariert.

Das ganze hat super funktioniert und bei meinem heutigen Test werden mir plötzlich 2 Fehler angezeigt. Nach kurzer nachforschung habe ich bemerkt das mir die Klasse IAPButton rot angezeigt wird.

Ich habe am Code nichts mehr verändert als ich es zuletzt getestet habe. Kann sich an den Einstellungen was verändert haben? 

Leider wird mir auch nicht vorgeschlagen eine weitere Bibliothek einzubinden oder ähnliches.

 

using System;
using System.Collections.Generic;
using System.Globalization;
using TMPro;
using UnityEngine;
using UnityEngine.Purchasing;
using UnityEngine.UI;

1467450312_Bildschirmfoto2022-10-17um19_07_39.thumb.png.17849ab41f2fe8f794d95ca759e7d27b.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...